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Warranty Statement
THE MATERIAL CONTAINED IN THIS DOCUMENT IS PROVIDED “AS IS,” AND IS SUBJECT 
TO BEING CHANGED, WITHOUT NOTICE, IN FUTURE EDITIONS. FURTHER, TO THE 
MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, AGILENT DISCLAIMS ALL 
WARRANTIES, EITHER EXPRESS OR IMPLIED WITH REGARD TO THIS MANUAL AND 
ANY INFORMATION CONTAINED HEREIN, INCLUDING BUT NOT LIMITED TO THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE. AGILENT SHALL NOT BE LIABLE FOR ERRORS OR FOR INCIDENTAL 
OR CONSEQUENTIAL DAMAGES IN CONNECTION WITH THE FURNISHING, USE, OR 
PERFORMANCE OF THIS DOCUMENT OR ANY INFORMATION CONTAINED HEREIN. 
SHOULD AGILENT AND THE USER HAVE A SEPARATE WRITTEN AGREEMENT WITH 
WARRANTY TERMS COVERING THE MATERIAL IN THIS DOCUMENT THAT CONFLICT 
WITH THESE TERMS, THE WARRANTY TERMS IN THE SEPARATE AGREEMENT WILL 
CONTROL.

DFARS/Restricted Rights Notice 
If software is for use in the performance of a U.S. Government prime contract or 
subcontract, Software is delivered and licensed as “Commercial computer software” as 
defined in DFAR 252.227-7014 (June 1995), or as a “commercial item” as defined in FAR 
2.101(a) or as “Restricted computer software” as defined in FAR 52.227-19 (June 1987) or 
any equivalent agency regulation or contract clause. Use, duplication or disclosure of 
Software is subject to Agilent Technologies’ standard commercial license terms, and 
non-DOD Departments and Agencies of the U.S. Government will receive no greater than 
Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users 
will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or 
DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

Certification 
Agilent Technologies, Inc. certifies that this product met its published specifications at the 
time of shipment from the factory. Agilent Technologies, Inc. further certifies that its 
calibration measurements are traceable to the United States National Institute of 
Standards and Technology, to the extent allowed by the Institute's calibration facility, and 
to the calibration facilities of other International Standards Organization members.
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Assistance 
Product maintenance agreements and other customer assistance agreements are available 
for Agilent Technologies, Inc. products. For information about these agreements and for 
other assistance, contact Agilent. Refer to “Agilent Support, Services, and Assistance” on 
page 1-8.

Safety and Regulatory Information
The safety and regulatory information pertaining to this product is located in Chapter, 
“Service, Safety and Regulatory Information”.

Statement of Compliance
This product has been designed and tested in accordance with accepted industry 
standards, and has been supplied in a safe condition. The documentation contains 
information and warnings that must be followed by the user to ensure safe operation and 
to maintain the product in a safe condition.

Definitions
• Specifications describe the performance of parameters covered by the product warranty 

(temperature –0 to 55 °C, unless otherwise noted.)

• Typical describes additional product performance information that is not covered by the 
product warranty. It is performance beyond specification that 80% of the units exhibit 
with a 95% confidence level over the temperature range 20 to 30 °C. Typical 
performance does not include measurement uncertainty.

• Nominal values indicate expected performance or describe product performance that is 
useful in the application of the product, but is not covered by the product warranty.

• Characteristic Performance describes performance parameter that the product is 
expected to meet before it leaves the factory, but is not verified in the field and is not 
covered by the product warranty. A characteristic includes the same guard bands as a 
specification.
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Safety Notes Service, Safety and Regulatory Information
Safety Notes
The following safety notes are used throughout this manual. Familiarize yourself with 
each of the symbols and its meaning before operating this instrument.

CAUTION Caution denotes a hazard. It calls attention to a procedure that, if not 
correctly performed or adhered to, could result in damage to or destruction of 
the instrument. Do not proceed beyond a caution note until the indicated 
conditions are fully understood and met.

WARNING Warning denotes a hazard. It calls attention to a procedure which, if 
not correctly performed or adhered to, could result in injury or loss 
of life. Do not proceed beyond a warning note until the indicated 
conditions are fully understood and met.

General Safety Considerations 

Safety Earth Ground 

WARNING This is a Safety Class I product (provided with a protective earthing 
ground incorporated in the power cord). The mains plug shall only 
be inserted in a socket outlet provided with a protective earth 
contact. Any interruption of the protective conductor, inside or 
outside of the instrument, will make the instrument dangerous. 
Intentional interruption is prohibited.

CAUTION Always use the three-prong AC power cord supplied with this product. Failure 
to ensure adequate grounding by not using this cord may cause product 
damage.

Cleaning the Instrument

WARNING To prevent electrical shock, disconnect the “Agilent Technologies 
N5261A and N5262A” from mains before cleaning. Use a dry cloth or 
one slightly dampened with water to clean the external case parts. 
Do not attempt to clean internally.
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Service, Safety and Regulatory Information     General Safety Considerations
Before Applying Power

CAUTION If this product is to be energized via an autotransformer make sure the 
common terminal is connected to the neutral (grounded side of the mains 
supply).

CAUTION This product is designed for use in Installation Category II and Pollution 
Degree 2.

CAUTION Always use the three prong AC power cord supplied with this product. Failure 
to ensure adequate earth grounding by not using this cord may cause product 
damage.

CAUTION The Mains wiring and connectors shall be compatible with the connector used 
in the premise electrical system. Failure, to ensure adequate earth grounding 
by not using the correct components may cause product damage, and serious 
injury.

CAUTION When installing the product in a cabinet, the convection into and out of the 
product must not be restricted. The ambient temperature (outside the 
cabinet) must be less than the maximum operating temperature of the 
product by 4 °C for every 100 watts dissipated in the cabinet. If the total 
power dissipated in the cabinet is greater than 800 watts, then forced 
convection must be used
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General Safety Considerations Service, Safety and Regulatory Information
Servicing 

WARNING If this product is not used as specified, the protection provided by 
the equipment could be impaired. This product must be used in a 
normal condition (in which all means for protection are intact) only.

WARNING These servicing instructions are for use by qualified personnel only. 
To avoid electrical shock, do not perform any servicing unless you 
are qualified to do so.

WARNING The opening of covers or removal of parts may expose dangerous 
voltages. Disconnect the instrument from all voltage sources while it 
is opened.

WARNING Procedures described in this document may be performed with 
power supplied to the product while protective covers are removed. 
Energy available at many points may, if contacted, result in personal 
injury.

WARNING The power cord is connected to internal capacitors that may remain 
live for 10 seconds after disconnecting the plug from its power 
supply. 

WARNING For continued protection against fire hazard, replace fuses, and or 
circuit breakers only with same type and rating. The use of other 
fuses, circuit breakers or material is prohibited.

WARNING The detachable power cord is the instrument disconnecting device. 
It disconnects the mains circuits from the mains supply before other 
parts of the instrument. The front panel switch is only a standby 
switch and is not a LINE switch (disconnecting device).

WARNING The opening of covers or removal of parts is likely to expose 
dangerous voltages. Disconnect the instrument from all voltage 
sources while it is being opened.
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Service, Safety and Regulatory Information     Electrostatic Discharge Protection
Electrostatic Discharge Protection
Protection against electrostatic discharge (ESD) is essential while removing assemblies 
from or connecting cables to the instrument. Static electricity can build up on your body 
and can easily damage sensitive internal circuit elements when discharged. Static 
discharges too small to be felt can cause permanent damage. To prevent damage to the 
instrument:

• always wear a grounded wrist strap having a 1 MΩ resistor in series with it when 
handling components and devices or when making connections to the test set.

• always use a grounded, conductive table mat while making connections.

• always wear a heel strap when working in an area with a conductive floor. If you are 
uncertain about the conductivity of your floor, wear a heel strap.

• always ground yourself before you clean, inspect, or make a connection to a 
static-sensitive device or test port. You can, for example, grasp the grounded outer shell 
of the test port or cable connector briefly.

• always ground the center conductor of a test cable before making a connection to the 
analyzer test port or other static-sensitive device. This can be done as follows: 

1. Connect a short (from your calibration kit) to one end of the cable to short the center 
conductor to the outer conductor.

2. While wearing a grounded wrist strap, grasp the outer shell of the cable connector.

3. Connect the other end of the cable to the test port. 

4. Remove the short from the cable.

Figure 1-1 shows a typical ESD protection setup using a grounded mat and wrist strap. 

Figure 1-1 ESD Protection Setup
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Regulatory Information
This section contains information that is required by various government regulatory 
agencies.

Instrument Markings

The instruction documentation symbol. The product is marked with this symbol 
when it is necessary for the user to refer to the instructions in the documentation.

This symbol indicates that the instrument requires alternating current (ac) input.

This symbol indicates separate collection for electrical and electronic equipment, 
mandated under EU law as of August 13, 2005. All electric and electronic equipment 
are required to be separated from normal waste for disposal (Reference WEEE 
Directive, 2002/96/EC).   

This symbol indicates that the power line switch is ON.

This symbol indicates that the power line switch is in the STANDBY position.

This symbol indicates that the power line switch is in the OFF position.

This symbol is used to identify a terminal which is internally connected to the 
product frame or chassis.

The CE mark is a registered trademark of the European Community. (If accompanied 
by a year, it is when the design was proven.)

The CSA mark is a registered trademark of the Canadian Standards Association. 
This instrument complies with Canada: CSA 22.2 No. 000000061010-1, Second 
Edition.

This is a symbol of an Industrial Scientific and Medical Group 1 Class A product.

This is a marking to indicate product compliance with the Canadian 
Interference-Causing Equipment Standard (ICES-001).

Direct Current.

This is a required mark signifying compliance with an EMC requirement. The C-Tick 
mark is a registered trademark of the Australian Spectrum Management Agency.

China RoHS regulations include requirements related to packaging, and require 
compliance to China standard GB18455-2001.

This symbol indicates compliance with the China RoHS regulations for 
paper/fiberboard packaging.

ICES/NMB-001 
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Service, Safety and Regulatory Information     Regulatory Information
Statement of Compliance

This product has been designed and tested in accordance with accepted industry 
standards, and has been supplied in a safe condition. The documentation contains 
information and warnings that must be followed by the user to ensure safe operation and 
to maintain the product in a safe condition

Declaration of Conformity

A declaration of conformity is on file for the PNA models, and a copy is available upon 
request, or a copy is available on the Agilent Technologies web site at 
http://regulations.corporate.agilent.com/DoC/search.htm

EMC Information 

Complies with European EMC Directive 2004/108/EC

• IEC/EN 61326-1
• CISPR Pub 11 Group 1, class A
• AS/NZS CISPR 11
• ICES/NMB-001

Safety Information 

Complies with European Low Voltage Directive 2006/95/EC

• IEC/EN 61010-1, Edition 2
• Canada: CSA C22.2 No. 61010-1:2004
• USA: UL 61010-1, Edition 2

Compliance with Canadian EMC Requirements 

This ISM device complies with Canadian ICES-001.
Cet appareil ISM est conforme a la norme NMB du Canada.

Compliance with German FTZ Emissions Requirements 

This product complies with the German FTZ 526/527 Radiated Emissions and Conducted 
Emission requirements.
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Agilent Support, Services, and Assistance

Service and Support Options

The N5261/62A Millimeter Head Controller has a one-year return to Agilent Technologies 
service warranty.

NOTE There are many repair and calibration options available from the Agilent 
Technologies support organization. These options cover a range of service 
agreements with varying response times. Contact Agilent for additional 
information on available service agreements for this product. Refer to 
“Contacting Agilent” on page 1-8. 

Contacting Agilent

Assistance with test and measurements needs and information or finding a local Agilent 
office are available on the Web at:
http://www.agilent.com/find/assist

If you do not have access to the Internet, please contact your Agilent field engineer.

NOTE In any correspondence or telephone conversation, refer to the Agilent product 
by its model number and full serial number. With this information, the 
Agilent representative can determine whether your product is still within its 
warranty period.

Shipping an Item to Agilent for Service or Repair

If you wish to send an item from your system to Agilent Technologies for service or repair:

• Include a complete description of the service requested or of the failure and a 
description of any failed test and any error message.

• Ship the item using the original or comparable antistatic packaging materials.

• Contact Agilent for instructions on where to ship the item. Refer to “Contacting Agilent” 
on page 1-8.
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General Product Information Introduction
Introduction
This document describes the N5261A and N5262A Millimeter Head Controller features 
and options, as well as connections to the N5242A PNA-X and Millimeter Head Modules. 
For further Banded Millimeter-Wave information, refer to Application Note 1408-15. 

Typical System Configurations 

Figure 2-1 2-Port Millimeter Wave Configuration (N5261A)

Figure 2-2 4-Port Millimeter Wave Configuration (N5262A)
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Description      General Product Information
Description
The N5261/62A Millimeter Head Controller provides the interface between the 
millimeter-wave test head modules and a PNA-X series network analyzer.

The Millimeter Head Controller, when used in conjunction with the millimeter-wave test 
head modules and the PNA-X, provides all of the features and functions of a full 
S-Parameter test set. 

The Millimeter Head Controller supplies RF and LO signals to the millimeter-wave test 
head modules and returns the down converted reference and test IF signals to the PNA-X 
for process and display. The N5261/62A Millimeter Head Controller also supplies the 
+12 V bias to each millimeter-wave head module. Refer to the Figure 5-1 through 
Figure 5-4 beginning on Page 5-5.

A typical system configuration is illustrated in Figure 2-1 and Figure 2-2 on page 2-2. 

Network Analyzer Requirements
The N5242A PNA-X requires the following option combinations for proper operation with 
the N5261/62A Millimeter Head Controller. 

• PNA-X firmware revision: N5242A Option 020 ≥ A.08.20.04 

• The N5261A with an N5242A Option 200 or 400 requires Option 020.

• The N5262A with an N5242A Option 200 requires Option 020 and 550 or 551 for 4-Port 
system.

• The N5262A with an N5242A Option 400 requires Option 020.

• The N5261A with an N5242A Option 219 or 224 requires Option 020.

• The N5262A with an N5242A Option 219 or 224 requires Option 020 and 550 or 551 for 
4-Port system.

• The N5262A with an N5242A Option 419 or 423 requires Option 020.
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General Product Information Available Options
Available Options

Accessory Options 

Installation instructions are included in the option package.

• Option 1CM - Rackmount Kit (5063-9215).

• Option 1CN - Front Handle Kit (5063-9228).

• Option 1CP - Rackmount with front handle Kit (5063-9222).

Cable Options 

An external amplifier is required for higher frequency millimeter wave modules with some 
cable option. Refer to Table 2-2, “Cable and Millimeter Module Combinations,” on page 2-8.

• Option 501 - 1-Port Millimeter Module Cable Set (48 in, 1.22 m) 

• Option 502 - 1-Port Millimeter Module Cable Set (79 in, 2 m) 

• Option 503 - 1-Port Millimeter Module Cable Set (118 in, 3 m) 

• Option 505 - 1-Port Millimeter Module Cable Set (197 in, 5 m) 

• Option 102 - Cable Set 2-Port PNA-X to Test Set 

• Option 104 - Cable Set 4-Port PNA-X to Test Set 
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Verifying Your Shipment      General Product Information
Verifying Your Shipment
Each N5261/62A Millimeter Head Controller product includes:

• The N5261/62A Millimeter Head Controller.

• Interconnection cables and adapters to interconnect the system components for the 
options ordered. Refer Table 2-1 on page 2-6. The N5242A PNA-X and Millimeter Heads 
must be ordered separately.

• The N5261/62A Millimeter Head Controller Operation and Service Guide (the 
document you are now reading). This document provides system connection and basic 
operation information, using an N5261/62A Millimeter Head Controller with banded 
millimeter-wave test head modules. Refer to Application Note 1408-15. 

WARNING The N5261/62A Millimeter Head Controller and the test head modules 
are sensitive to electrostatic discharge (ESD). Ground your work 
station before unpacking and installing the test head modules. See 
“Electrostatic Discharge Protection” on page 1-5.

For a list of components shipped with your N5261/62A, refer to Table 2-1, “N5261/62A 
Contents,” on page 2-6.

Keep the shipping containers until the N5261/62A component checklist has been 
completed, and the components have been checked for physical damage. 

If the shipping container is damaged or the packaging material shows signs of stress, 
notify the carrier as well as the Agilent Technologies Field Engineer. Keep the shipping 
materials for the carrier’s inspection. Agilent Technologies will arrange for repair or 
replacement of damaged equipment without waiting for a claim settlement from the 
carrier. Refer to “Contacting Agilent” on page 1-8.
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General Product Information Verifying Your Shipment
Contents List

Use the table below to verify that the shipment is complete. 

Table 2-1 N5261/62A Contents  

✔

Agilent 
Part Number Qty Description

N5261A or N5262A 1 Millimeter Head Controller

N5242-20138 1 Right Foot

N5242-20139 1 Left Foot

5023-0132 1 Locking Feet Kit

0515-2317 2 Screw

8120-6818 1 Test Set Interface Cable (W7)

1810-0118 1 50 Ohm Load Termination (N5261A)

1810-0118 2 50 Ohm Load Termination (N5262A)

9230-0333 1 Envelope (Calibration Certificate)

9320-6636 1 Functional Certificate

N5262-90001 1 Installation and Service Guide

Option 1CM (Rackmount Kit)

5063-9251 1 Rackmount Kit

Option 1CN (Rackmount Kit)

5063-9228 1 Front Handle Kit

Option 1CP (Rackmount Kit)

5063-9222 1 Rackmount Kit with Front Handle Kit 

N5261A Option 102 (Cable Set 2-Port PNA-X to Test Set)

5061-9038 6 Rear Panel Cable Assembly   (W2, W8)

N5262-20016 1 RF Cable, SRC1 to 2-Port PNA-X (W3)

N5261AOption 104 (Cable Set 4-Port PNA-XPNA-X to Test Set)

5061-9038 6 Rear Panel Cable Assembly (W2, W8)

N5262-20018 1 RF Cable, SRC1 to 4-Port PNA-X (W1)

N5262A Option 102 (Cable Set 2-Port PNA-X to Test Set)

5061-9038 7 Rear Panel Cable Assembly (W2, W8)

N5262-20016 1 RF Cable, SRC1 to 2-Port PNA-X (W3)

N5262-20017 1 RF Cable, SRC2 to 2-Port PNA-X (W4)

N5262A Option 104 (Cable Set 4-Port PNA-X to Test Set)

5061-9038 8 Rear Panel Cable Assembly (W2, W8)
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Verifying Your Shipment      General Product Information
N5262-20018 1 RF Cable, SRC1 to 4-Port PNA-X (W1)

N5262-20019 1 RF Cable, SRC2 to 4-Port PNA-X (W2)

Option 501 (1-Port Millimeter Module Cable Set (48 inches = 1.2 meter) 

8121-1221 2 RF 3.5 mm cable (RF Input and LO Input)

85105-60030 1 Cable Assembly, DC Power (Bias)

N5260-60025 1 IF Cable Assembly (REF IF and TEST IF)

Option 502 (1-Port Millimeter Module Cable Set (79 inches = 2 meter)

N5260-60023 2 RF 3.5 mm cable (RF Input and LO Input)

N5260-60024 2 IF Cable Assembly (REF IF and TEST IF)

N5260-60025 1 Cable Assembly, DC Power (Bias)

Option 503 (1-Port Millimeter Module Cable Set (118 inches = 3 meter)

N5260-60026 2 RF 3.5 mm cable (RF Input and LO Input)

N5260-60027 2 IF Cable Assembly (REF IF and TEST IF)

N5260-60028 1 Cable Assembly, DC Power (Bias)

Option 505 (1-Port Millimeter Module Cable Set (197 inches = 5 meter)

N5260-60029 2 RF 3.5 mm cable (RF Input and LO Input)

N5260-60030 2 IF Cable Assembly (REF IF and TEST IF)

N5260-60031 1 Cable Assembly, DC Power (Bias)

Table 2-1 N5261/62A Contents (Continued) 
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General Product Information Compatible Millimeter Wave Modules
Compatible Millimeter Wave Modules

OML Millimeter Heads 

The Olsen Microwave Lab (OML) Millimeter-Wave Modules can be ordered from Agilent. 
There are millimeter-wave modules available with frequency ranges up to 500 GHz. For 
further Banded Millimeter-Wave information, refer to Application Note 1408-15. 

Figure 2-1 and Figure 2-2 are typical configurations, shown with the N5260W15 
millimeter heads.

You may also refer to Banded Millimeter-wave Solutions up to 500 GHz, available on the 
Web at: http://www.home.agilent.com and search banded millimeter. 

CAUTION Turn off the N5261/62A power when connecting or disconnecting the 
millimeter heads or permanent damage can occur to the millimeter modules. 

The test set can drive the following cable/head combinations. An external amplifier is 
required for higher frequency millimeter wave modules. 

To determine the required amplification for RF OUT or LO OUT, refer to Table 2-3 and 
Figure 2-3. 

Figure 2-3 RF Cable Loss (dB loss per foot)

Table 2-2 Cable and Millimeter Module Combinations

Cable 
Option

Cable Length RF OUT 
(compatible heads)

LO OUT
(compatible heads)

501 4 ft. (1.22 m) 50 to 500 GHz 50 to 500 GHz

502 6.58 ft. (2 m) 50 to 500 GHz 50 to 500 GHz

503 9.83 ft. (3 m) 50 to 500 GHz 50 to 325 GHz

505 16.4 ft. (5 m) 50 to 110 GHz None 
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Caring for Waveguide (WG) Interfaces      General Product Information
If you are installing an amplifier in the LO or RF path, ensure the amplifier’s input is 
connected to the test set, and the output is connected to the millimeter head. 

Caring for Waveguide (WG) Interfaces
A clean surface at millimeter-wave frequencies is much more important than at lower 
frequencies because any debris on the waveguide surface can potentially distort the 
measurement results.

Caring for WG interfaces is not difficult. Dirt and dust can be removed using the following:

• Isopropyl alcohol 99.5%1

• Lint-free cloth
• Pressurized air (for dust removal)

To remove dirt on the waveguide surface, simply put a few drops of isopropyl alcohol on a 
lint-free cloth and gently wipe the surface.

To remove dust, simply spray the pressurized air on the waveguide surface.

Table 2-3 LO and RF Power Requirements

Millimeter Head RF INPUT LO INPUT

WR-15 
50 to 75 GHz

12.5 to 18.8 GHz
+5 to 13 dBm

10 to 15 GHz
+5 to 13 dBm

WR-12 
60 to 90 GHz

10 to 15 GHz
+5 to 13 dBm

12 to 18 GHz
+5 to 13 dBm

WR-10 
75 to 110 GHz

12.5 to 18.4 GHz
+5 to 13 dBm

9.3 to 13.8 GHz
+5 to 13 dBm

WR-08 
90 to 140 GHz

7.5 to 11.2 GHz
+7 dBm min

11.2 to 17.5 GHz
+7 dBm min

WR-06 
110 to 170 GHz

9.1 to 14.2 GHz
+7 dBm min

11 to 17 GHz
+7 dBm min

WR-05 
140 to 220 GHz

11.6 to 18.4 GHz
+7 dBm min

11.6 to 18.4 GHz
+7 dBm min

WR-03 
220 to 325 GHz

12.2 to 18.1 GHz
+7 dBm min

12.2 to 18.1 GHz
+7 dBm min

WR-02.2 
325 to 500 GHz

10.8 to 16.7 GHz
+10 dBm min

11.6 to 17.9 GHz
+10 dBm min

1. Use isopropyl alcohol only in a well-ventilated area. Allow all residual alcohol moisture to 
evaporate, and the fumes to dissipate, prior to assembling waveguide interfaces.
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General Product Information Specifications
Specifications
There are no specifications or typical specifications for the PNA-X + N5261/62A + OML 
banded millimeter wave configuration. There are some limited typical specifications for 
the OML millimeter wave modules which can be found on the OML website 
(http//www.omlinc.com). The only two OML typical specifications that apply for the field to 
perform are dynamic range and coupler directivity.

Supplemental Characteristics

The supplemental characteristics provide information useful in applying the instrument 
by giving typical, but non–warranted, performance parameters. 

The connectors listed in Table 2-4 must be torqued to 57 N-cm (5 in-lb).

CAUTION The damage level for TEST IF and REF IF is +17 dBm and dc ±1 V. 
The damage level for SRC1 and SRC 2 RF IN is +15 dBm. 

Table 2-4 N5261/62A Supplemental Characteristics 

Front/Rear Panel 
Connectora 

a. All connectors are SMA.

Power Frequency 
Range

RF OUT +12.5 dBmb

b. Gain is 12 to 35 dB, ALC range > 40 dB.

7 to 20 GHz

LO OUT +12.5 dBm 8 to 19 GHz

TEST IF (out of the module) −27 dBm 1 to 20 MHz

REF IF (out of the module) −27 dBm 1 to 20 MHz

LO IN +2 to −11 dBm 8 to 19 GHz

Test IF to AD IF OUT −6 dBc

c. Relative to the TEST IF power level.

1 to 20 MHz

REF IF to AD IF OUT −13 dBd

d. Relative to the REF IF power level.

1 to 20 MHz

REF IF to R IF OUT −11 dBc 1 to 20 MHz

SRC 1 RF IN +15 dBm 7 to 20 GHz

SRC 2 RF IN +15 dBm 7 to 20 GHz
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Specifications      General Product Information
Environmental Requirements

The environmental requirements of the N5261/62A are listed in the table below. Note that 
these requirements are the same as those of the N5242A network analyzer with 
Option 020.

NOTE Samples of this product have been type-tested in accordance with the Agilent 
Environmental Test Manual and verified to be robust against the 
environmental stresses of storage, transportation and end-use; those stresses 
include but are not limited to temperature, humidity, shock, vibration, 
altitude and power-line conditions. Test methods are aligned with IEC 
60068-2 and levels are similar to MIL-PRF-28800F Class 3.

Heating and Cooling in the Operating Environment

Install air conditioning and heating, if necessary, to maintain the ambient temperature 
within the appropriate range as given in Table 2-5. 

Required Conditions for Accuracy Enhanced Measurement

Accuracy-enhanced (error-corrected) measurements require the ambient temperature of 
the N5261/62A to be maintained within ± 1 °C of the ambient temperature at calibration.

CAUTION This product is designed for use in Installation Category II and Pollution 
Degree 2.

Table 2-5 N5261/62A Operating Environment 

Temperature

Operation                                            0 °C to 40 °C (32 °F to 104 °F)

Storage                                               –40 °C to +70 °C (–40 °F to +158 °F) 

Measurement Calibration                   20 °C to 26 °C (68 °F to 79 °F)

Performance Verification                   Temperature must be within 1 °C (1.8 °F) of 
the temperature at which the measurement 
calibration was performed.

Pressure Altitude                       
(Operation or Storage) 

0 to 3000 meters (9842 feet)

Enclosure Protection IP 2 0, according to IEC 529

Power 100/120/220/240 V 50/60 Hz 
(200 Watt typical and 350 Watt maximum)
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General Product Information Specifications
Component Weight and Dimensions

Table 2-6 illustrates the maximum weight and dimensions of the system components. 

Table 2-6 Weights and Dimensions

 Model Weight Height Width Depth

Millimeter-wave module (each) 3.5 kg 
(7.5 lb, ± 0.5 lb)

6.9 cm 
(2.7 in)

33.0 cm 
(12.9 in)

17.8 cm
(6.9 in)

N5242A PNA-X 29 Kg 
(64 lb) nominal

26.7 cm 
(10.5 in)

42.5 cm
(16.7 in)

42.6 cm
(16.8 in)

N5261/62A millimeter- head 
controller

11 kg (24.2 lb) 18 cm 
(7.1 in)

42.5 cm 
(16.75 in)

42.5 cm 
(16.75 in)
2-12 User’s Guide N5262-90001



Front Panel Features      General Product Information
Front Panel Features

Figure 2-4 N5262A Front Panel Features

1. Line Switch. This switch turns the instrument ON or OFF. When the side of the 
switch labeled 0 is depressed, the instrument is OFF; when the side of the switch 
labeled 1 is depressed, the instrument is ON.

2.  Active LED.

• When the test set power switch is On and is connected and addressed by a PNA-X, 
the LED is On (illuminated).

• The LED is Off (not illuminated) when the test set power switch is in Standby, or not 
addressed by a PNA-X.

3. Port Source LED. This LED indicates which port is selected when addressed by the 
PNA-X RF Source. 

4. RCVR Port LED. This LED indicates which port is selected as the Receiver port.

5. RF OUT. Provides an amplified RF source signal to the millimeter-wave head module.

6. LO OUT. Provides amplified LO signal to the millimeter-wave head module.

7. TEST IF. IF signal input connection from the millimeter module. 

8. REF IF. Reference IF signal input connection from the millimeter module.

9. DC Power (Bias). This bias supplies the +12.5 volts DC and ground lines to the 
millimeter wave head modules. Pins 1 and 3 are both +12.5 Vdc supplies. Pins 4 and 6 
are the dc supply ground lines. Pins 2, 5, and 7 are unused.

10. SRC1. Connects to the front panel PNA-X test ports.

11. SRC2. Connects to the front panel PNA-X test ports.

NOTE The SRC2 Input and Ports 3 and 4 features are not present on the N5261A. 
Refer to Figure 2-1 on page 2-2.

           

                  

Line Switch                                 Over Current LEDs             DC Power

Active
LED

SRC1 and SRC2 Inputs           Port Status LEDsLO Out

REF IF
RF Out

TEST IF
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General Product Information Rear Panel Features
Rear Panel Features

Figure 2-5 N5261/62A Rear Panel Features

1. Chassis Ground.

2. LO IN.This input is from the LO drive of the PNA-X. The signal is split and amplified 
then output to the front panel of the N5261/62A.

3. D IF Output. IF signal from the test set to the PNA-X IF D Input.

4. C IF Output. IF signal from the test set to the PNA-X IF C Input.

5. R IF Output. REF IF from the test set to the PNA-X IF R Input.

6. A IF Output. IF signal from the test set to the PNA-X IF A Input.

7. B IF Output. IF signal from the test set to the PNA-X IF B Input.

8. Test Set Interface I/O. The Test Set Interface connector is used to send address and 
data to the test set from the PNA-X.

9. Pass Through Interface. Connection to another test set.

10.SRC 1 RF IN and SRC 2 RF OUT. Jumpers are not shown (E8356-20072).

11.SRC 2 RF IN and SRC 2 RF OUT. Jumpers are not shown (E8356-20072).

 

             

                                                                     

 Line Module          Test Set I/O                                Chassis Ground      

   IF Outputs                 LO IN SRC2 IN/OUT   SRC1 IN/OUT
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Rear Panel Features      General Product Information
12.Line Module. This assembly houses the line cord connection, line fuse, and line voltage 
selector. Pull out the topside of the line module cover to replace or change the fuse. Line 
voltage selection is automatic and no setting is required. Recommended fuse values are 
printed on the rear panel of the N5261/62A.

WARNING For continued protection against fire hazard replace line fuse only 
with same type and rating:
• F 5A/250V, Part Number 2110-0709

The use of other fuses or material is prohibited.

WARNING For continued protection against fire hazard, replace fuses, and or 
circuit breakers only with same type and rating. The use of other 
fuses, circuit breakers or material is prohibited.

CAUTION This instrument has autoranging line voltage input, be sure the supply 
voltage is within the specified range. 
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System Configuration and Operation Site Preparation
Site Preparation

Protect Against Electrostatic Discharge (ESD)

This is important. If not properly protected against, electrostatic discharge can seriously 
damage your analyzer, resulting in costly repair.

CAUTION To reduce the chance of electrostatic discharge, follow all of the 
recommendations outlined in “Electrostatic Discharge Protection” on page 
1-5.

WARNING No operator serviceable parts inside. Refer servicing to qualified personnel. 
To prevent electrical shock do not remove covers. 

Power Requirements

Before installing the PNA-X and N5261/62A, be sure that the required AC power is 
available at all necessary locations.

• Three-wire power cables (which provide a safety ground) must be used with all 
instruments.

• Air-conditioning equipment (or other motor-operated equipment) should not be placed 
on the same ac line that powers the system.

• The table below lists the maximum VA ratings and BTU/hour ratings for all 
instruments in the configuration. This table can be used to determine both the electrical 
requirements and the air conditioning requirements of the system.

Table 3-1 Power Requirements of a Standard Configuration

Standard Equipment

Instrument Maximum Watt 

N5242A with Option 020 270

N5261/62A Millimeter Head Controller 350

Millimeter-wave modules (powered from controller)

Total 620
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System Setup with N5242A      System Configuration and Operation
System Setup with N5242A 
Install the instrument so that the detachable power cord is readily identifiable and is 
easily reached by the operator. The detachable power cord is the instrument disconnecting 
device. It disconnects the mains circuits from the mains supply before other parts of the 
instrument. The front panel switch is only a standby switch and is not a LINE switch. 
Alternatively, an externally installed switch or circuit breaker (which is readily 
identifiable and is easily reached by the operator) may be used as a disconnecting device.

WARNING This is a Safety Class 1 Product (provided with a protective earthing 
ground incorporated in the power cord). The mains plug shall only 
be inserted in a socket outlet provided with a protective earth 
contact. Any interruption of the protective conductor inside or 
outside of the product is likely to make the product dangerous. 
Intentional interruption is prohibited.

WARNING The opening of covers or removal of parts is likely to expose 
dangerous voltages. Disconnect the instrument from all voltage 
sources while it is being opened.

Preparing the N5242A Network Analyzer

The main power cord can be used as the system disconnecting device. It disconnects the 
mains circuits from the mains supply.

1. Remove the feet from the bottom of the network analyzer. Refer to Figure 3-1. 

2. Remove the 2 lower standoffs and screws (0515-1619) from the rear panel on the 
network analyzer. 

Figure 3-1 Rear Bottom Feet

Standoffs (x2)

Feet (x4)
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System Configuration and Operation System Setup with N5242A
3. Install the two rear locking feet (5023-0132) onto the PNA-X, using the included screws 
(0515-1619), where the standoffs were removed. 

Figure 3-2 Install Locking Feet on N5242A

4. Install the two rear locking feet onto the N5261/62A. Looking at the front panel, the 
N5242-20138 is the right foot and the N5242-20139 is the left foot. Two screws 
(0515-2317) are included with this option. 

Figure 3-3 Install Locking Feet on N5261/62A

Locking Feet
(5023-0132)Included in package

Screws (0515-1619)
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System Setup with N5242A      System Configuration and Operation
5. Place the network analyzer on top of the Test Set and ensure that the front frame of the 
network analyzer is positioned slightly forward of the locks that are attached to the Test 
Set. Slide the network analyzer back so the locks engage the front frame of the analyzer. 

Figure 3-4 Locking the Analyzer’s

Test Set
Front Frame

Network Analyzer
Front Frame

Slide the network Analyzer
back to engage the lock link
in the back of the network
analyzer's front frame

Lock Link
screw
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System Configuration and Operation System Setup with N5242A
6. Secure the network analyzer’s lower locking feet to the Test Set upper locking feet, 
using the spring–loaded screws on the locking feet. Refer to Figure 3-5. If the network 
analyzer's lower locking feet are not aligned with the screw holes in the Test Set's upper 
locking feet, loosen the screws securing the feet to the instrument slightly to align. 

Figure 3-5 Locking Feet Screws

NOTE There are two Lock-Feet kits available. Refer to “Contacting Agilent” on page 
1-8 for ordering information. 

• PNA-X − 5023-0132 (Kit includes locking feet and screws)
• Test Set − N5242-20138 is the right foot and the N5242-20139 is the left 

foot.

• Screw − 0515-2317
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System Setup with N5242A      System Configuration and Operation
Front Panel Cabling 

The test head modules are placed on the work surface in front of the PNA-X and head 
controller as shown. Figure 2-1 and Figure 2-2 on page 2-2. 

Connect the front panel interconnect cables from the PNA-X to the N5261/62A Millimeter 
Head Controller. The rear panel jumper (SCR1 and SCR2) must be installed if you are 
using a front panel SRC cable (W1 - W4). Refer to Table 2-1 on page 2-6 for your specific 
option cable part numbers. Refer to Figure 3-6 and Figure 3-7.

Figure 3-6 N5261A System RF Cable

Figure 3-7 N5262A System RF Cables

w1 w1

N5242A with Opt 400 N5242A with Opt 219, 223

w1 w2 w3 w4
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System Configuration and Operation System Setup with N5242A
Test Head Module Connections

Install the front-panel interconnections between the N5261/62A Millimeter Head 
Controller and the modules as shown in Figure 3-8. Refer to Table 2-1 on page 2-6 for your 
specific option cable part numbers. 

If a millimeter head is not installed on a port, a 50 Ohm termination (1810-0118) must be 
installed on the N5261A or N5262A LO OUT connector.

CAUTION Turn off the N5261/62A power when connecting or disconnecting the 
millimeter heads or permanent damage can occur to the millimeter modules. 

Attaching cables to the connectors is easiest if they are attached in the following sequence: 

Figure 3-8 N5262A System Millimeter Head Connections

Table 3-2 Millimeter Head Controller Connections

Sequence From: Millimeter Head To: N5261A or N5262A

1 DC Power; +12V @ 1.5A (Bias) DC Power

2 RF INPUT; SMA connector RF Outa

a. Option 505 or 503 cable sets require external amplifiers, due to the RF insertion 
loss of the LO and RF signals into the module. Refer to “Compatible Millimeter 
Wave Modules” on page 2-8.

3 LO INPUT; SMA connector LO Outa

4 Ref IF; SMA connector REF IF

5 Test IF; SMA connector TEST IF

DC Bias
REF IF

TEST IF
RF LO
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System Setup with N5242A      System Configuration and Operation
Rear Panel Cabling

1. Connect the PNA-X rear panel IF INPUTS to the test set IF OUTPUTs (D, C, R, B and 
A), using cables (5061-9038).

2. Connect the test set LO IN to the PNA-X LO OUT (J5), using cables (5061-9038). 

3. Connect the test set I/0 cable (8120-6818) from the PNA-X to the N5261/62A Millimeter 
Head Controller. 

4. If you are not using the front panel connections. Connect the PNA-X SW SRC Out (J11) 
to SRC1 IN using cable (W2, 5061-9038). IF you are using the front panel cables, ensure 
that the jumpers (E8356-20072) are installed. Refer to Figure 3-9 and Figure 3-10.

Figure 3-9 2-Port Rear View Cabling 

Figure 3-10 4-Port Rear View Cabling 

w7

w8 (x5) w2

N5261/62A with N5242A with Opt 219, 224N5261/62A with N5242A with Opt 200

w7

w8 (x6) w5 w6

N5262A with N5242A Opt 419 and 423N5262A with N5242A Opt 400
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System Configuration and Operation Controlling the N5261/62A with the N5242A
Controlling the N5261/62A with the N5242A
This section will describe how to setup and operate the N5261/62A Millimeter Head 
Controller with the N5242A. 

The N5261/62A Millimeter Head Controller is considered a “slave” instrument. An 
N5242A must be used to control the Test Set. 

• PNA-X firmware revision: 
N5242A Option 020 ≥ A.08.20.04 

Visit our website for firmware revision and downloads.
http://na.tm.agilent.com/pna/firmware/firmware.htm

CAUTION Before switching on this instrument, make sure the supply voltage is in the 
specified range.

PNA-X Millimeter Mode 

The PNA-X multiport mode selects the application that will enable the PNA-X to control 
the N5261/62A Millimeter Head Controller. The PNA-X millimeter mode allows you to 
configure the system for the millimeter head you are using. Refer to the PNA-X Help 
system for more information. 

The N5242A Option 020 (IF Input) is required for in the PNA-X for the Millimeter mode of 
operation.

Figure 3-11 N5242A Options 
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How to Access Millimeter Mode

1. The Option 020 must be installed for Millimeter capability. To access the millimeter 
application select [System] > Configure > Millimeter Module. See Figure 3-12. 

Figure 3-12 Selecting Millimeter Mode

2. Select New. See Figure 3-13.

Figure 3-13 Millimeter Module Configuration

2
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System Configuration and Operation Controlling the N5261/62A with the N5242A
3. In the “Selected Configuration” dialog enter a title, such as WR15 or Millimeter 
PNA-X. See Figure 3-14.

4. Select the test set you are using from the drop down menu (N5261A or N5262A).

Figure 3-14 Select Test Set

5. Check “Route PNA RF to rear panel “SW SRC OUT” if you are using a PNA-X with 
Option 223 or 423 (rear panel RF OUT) and have connected the PNA-X SW SRC OUT 
(J11) to the test set rear panel SRC IN. 

6. If you are not using the front panel connections. Connect the PNA-X SW SRC Out (J11) 
to the test set SRC1 IN using cable (W2, 5061-9038). IF you are using the front panel 
cables, ensure that the jumpers (E8356-20072) are installed.

7. Uncheck “Enable Test Set RF ALC” if you would like to set the power level into the 
millimeter head. This would be useful to test amplifiers and other devices that require 
lower than the maximum power delivered by the millimeter head module. 

If the box is not checked the power will be set at +11 dBm, the default maximum power 
limit. You may adjust the power in the “Max power Limit” dialog box.   

The ALC mode is normally turned on to ensure that the module is operating at the 
proper level. The ALC is turned off when in pulse mode. Use care when ALC mode is off 
to prevent the module from being over-driven.
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Controlling the N5261/62A with the N5242A      System Configuration and Operation
8. Enter the Multiplier RF IN number. (WR15 = 4), (WR10 = 6) Table 3-3.

9. Enter the Multiplier LO IN number. (WR15 = 5), (WR10 = 8) Figure 3-15..

10.In the “Test Port Frequency” dialog box enter the Start and Stop Frequency of the 
millimeter head. (WR15 = 50 GHz/75 GHz), (WR10 = 67 GHz/110 GHz) 

11.Press Ok. The PNA will preset for millimeter operation. 

The Millimeter Head Modules are now the source and receiver ports of the system. The 
PNA-X ports 1 thru 4 are no longer enabled. 

Figure 3-15. New Configuration System Name

Table 3-3 RF and LO Harmonic Multipliers 

Band Freq Range of 
Operation 

(GHz)

RF Freq 
Range 
(GHz)

RF 
Harmonic 
Multiplier

LO Freq Range 
± IF Offset 

(GHz)

LO 
Harmonics 
Multiplier

WR-15 50 to 75 12.5 to 18.8 N=4 10.0 to 15.0 M=5

WR-12 60 to 90 10.0 to 15 N=6 12.0 to 18.0 M=5

WR-10 75 to 110 12.5 to 18.4 N=6 9.3 to 13.8 M=8

WR-08 90 to 140 7.5 to 11.7 N=12 11.2 to 17.5 M=8

WR-06 110 to 170 9.1 to 14.2 N=12 11.0 to 17.0 M=10

WR-05 140 to 220 11.6- to 18.4 N=12 14.7 to 18.0 M=12

WR-04 170 to 260 8.5 to 13 N=20 12.1 to 18.6 M=14

WR-03 220 to 325 12.2 to 18.1 N=18 12.2 to 18.1 M=18

5 or 6

9
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Calibrating the System 

This section will provides information to calibrate the Network Analyzer millimeter-wave 
system, using waveguide mechanical standards. Refer to the PNA-X Help menu for further 
information.

1. Set the systems Frequency Range, IF Bandwidth and Number of Points to be used in 
your measurements.

2. Press [CAL] > CAL Wizard on the PNA-X.

3. Select SmartCal (GUIDED Calibration), or UNGUIDED Calibration > Next.

Figure 3-16 Cal Method

4. Select the ports to be calibrated > Next.

Figure 3-17 Select Ports for Smart Cal 
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5. Press View/Select Cal Kit for an Unguided Cal.

Figure 3-18 Select Ports for Unguided Cal

6. Select the required Cal Kit from the drop-down menu for the waveguide band you are 
using. If you are performing an unguided Cal, select SOLT or TRL in “Choose class 
type”. 

7. Press Ok > Next.

Figure 3-19 Unguided Cal Kit List 

Figure 3-20  Guided Cal Kit List (SmartCal)
User’s Guide N5262-90001 3-15



System Configuration and Operation Controlling the N5261/62A with the N5242A
8. Press the individual keys to measure each Mechanical Standard or Thru. Follow the 
prompts for Smart Cal.

9. Press Next when all of the Mechanical Standards have been measured. 

Figure 3-21 Unguided Cal Mechanical Standards

Figure 3-22 Smart Cal Prompt

10.Press Save As User CalSet to save the calibration.

Figure 3-23 Save Cal
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Test Methods
There are two methods to verify your system. 

• Individual operational check for the N5261A or N5262A (non-system).

• Operational check for the system.

Non-System Operation Check

The following procedure verifies the N5261/62A without system components. 

Required Equipment (not included with 

• A PNA with a 20 GHz frequency range. N5230A, N5242A, E8362B, or equivalent 
network analyzer with test set I/O interface.

• Two RF flexible cables with 3.5 mm connectors (5062-6696 or equivalent).

• Three SMA adapters (female to female).

• Volt meter.

1. Turn on the PNA-X and N5261/62A. 

2. Verify that the PNA-X is in “Standard PNA” mode.

3. Verify DC voltage supplies on each of the front panel DC power connectors. 
Pins 1 and 3 = +12 V, Pins 4 and 6 = ground

4. Measure the LO OUT and SRC1 & SRC2 RF paths: 

a. Connect the test set I/O cable from the PNA to the N5261A or N5262A. 

b. Press [Preset].

c. Press [Freq] > Start > [7 GHz].

d. Press Stop > [20 GHz].

e. Press [Power] > [−30] > [Enter].

f. Press [Meas] > S12.

g. Connect the RF cables with adapters to the PNA-X Port 1 and Port 2.

h. Connect the two RF cables together with adapter.

i. Normalize the trace. Press [Memory] > Normalize. You will see a flat line at 0 dB.

1 3

6 4

2

5

7

n5260_001_304

Pin 3 (+12V)Pin 1 (+12V)

Pin 6 (gnd) Pin 4 (gnd)
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j. Remove the adapter from the cables and connect the Port 2 cable to the rear panel 
LO IN.

k. Connect the PNA-X Port 1 to test set port LO OUT and verify the LO Output power. 
Refer to Table 4-1 and Figure 4-1. Repeat this step for each LO OUT Port.

l. Remove the SRC1 IN to SRC1 OUT rear panel jumper.

m. Connect the PNA-X Port 1 to the test set SRC1 IN.

n. Connect Port 2 to the rear panel SRC1 OUT.

o. Verify the power loss. The trace typically slopes down at −1 dBm to −2 dBm. Refer to 
Table 4-1. 

p. Remove the SRC2 IN to SRC2 OUT rear panel jumper and repeat for SRC2 IN and 
SRC2 OUT. 

Figure 4-1 LO Output Power

Table 4-1 SRC1/2 and LO RF Path Measurement 

From the Rear Panel To the Front Panel Measure Gain/Loss

SRC1 OUT SCR1 IN −1 dB (±1 dB)

SRC2 OUT (N5262A) SCR2 IN (N5262A) −1 dB (±1 dB)

LO IN LO OUT +30 dB (±5 dB)
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5. Measure RF OUT. 

a. Re-install the SRC1 IN to SRC1 OUT rear panel jumper.

b. Press [Preset].

c. Press [Freq] > Start > [7 GHz].

d. Press Stop > [20 GHz].

e. Press [Power] > [−20] > [Enter].

f. Press [Meas] > S12.

g. Connect the two RF cables together with adapter.

h. Normalize the trace. Press [Memory] > Normalize. 

i. Remove the adapter and connect Port 2 to SRC1 IN.

j. Connect the PNA-X Port 1 to the test set RF OUT. 

k. Select Trace/Chan > Channel > Hardware Setup > Interface Control in the 
drop-down menu. Check “Enable Interface Control” and send the I/O command 0.1 in 
the “Test Set I/0 Control (addr.data)” window > OK. Verify the power level using 
Table 4-2 on page 4-5 and Figure 4-2 on page 4-5.

NOTE The PNA-X Series Network Analyzer comes with the Interface Control 
application. Information regarding this application can be found in the PNA’s 
Help System Menu, InterfaceControl. The application is shown below.
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l.  Repeat step j and step k for Ports 2, 3 and 4 TEST IF ports. When verifying Ports 3 
and 4 move the Port 2 cable to SRC 2 IN. Refer to Table 4-2 for the I/O command.

m. Measure S11 on Port 1. Press [Meas] > S11. Send command for Port 2. This 
measures the solid state load for RF Output Port 1 (< −10 dB). 

n. Measure S11 on Ports 2, 3, and 4. Send the command for Port 1. This measures the 
solid state loads for RF Outputs 2, 3 and 4 (< −10 dB). 

Figure 4-2 RF Output Power

Table 4-2 RF Path Measurement Table

From the Front Panel To the Front Panel Command Gain

SRC1 IN Port 1 RF OUT 0.1 20 dB (±5 dB)

SRC1 IN Port 2 RF OUT 0.2 20 dB (±5 dB)

SRC2 IN (N5262A) Port 3 RF OUT 0.16 20 dB (±5 dB)

SRC2 IN (N5262A) Port 4 RF OUT 0.32 20 dB (±5 dB)
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6. Measuring the TEST IF and REF IF Inputs to A, B, C, D and R Outputs. Refer to Table 
4-3 on page 4-7.

a. Connect the test set I/O cable from the PNA to the N5261A or N5262A. 

b. Press [Preset].

c. Press [Freq] > Start > > [10 MHz].

d. Press Stop > [20 MHz].

e. Press [Power] > [−20] > [Enter].

f. Press [Measure] > S21.

g. Connect the two RF cables together with adapter.

h. Normalize the trace. Press [Memory] > Normalize. 

i. Remove the adapter and connect the PNA-X Port 1 to the front panel test set Port 1, 
TEST IF.

j. Connect Port 2 to the test set A IF OUT on the rear panel. 

k. Select Trace/Chan > Channel > Hardware Setup > Interface Control. Check Enable 
Interface Control and send the I/O command 16.8 in the “Test Set I/0 Control 
(addr.data)” window > OK. Verify the power level using
 Table 4-3.

l. Repeat step j and step k for each TEST IF port.

m. Connect the PNA Port 1 to the front panel Port 1 REF IF.

n. Connect Port 2 to the rear panel D IF OUT. 

o. Send the I/O command 16.8 and verify the power level. Refer to Table 4-3.

p. Repeat step m, step n and step o for each REF IF port. 
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7. Verifying front panel LEDs.

a. Connect the test set I/O cable from the PNA to the N5261A or N5262A. 

b. Send the TEST I/O command 64.17 and verify the Active LED (amber) and Port 1 
Source (amber) & Receiver (green) Status LEDs are on. 

c. Send the TEST I/O command 64.34 and verify Port 2 S & R Status LEDs are on. 

d. Send the TEST I/O command 64.68 and verify Port 3 S & R Status LEDs are on. 

e. Send the TEST I/O command 64.136 and verify Port 4 S & R Status LEDs are on. 

f. Verify that the DC power LEDs are on. 

Table 4-3 IF Path Measurement 

From the TEST IF 
Front Panel

To the Rear 
Panel IF OUT

Command Gain

Port 1 TEST IF A 16.8 −6 dBm (±1 dB)

Port 2 TEST IF B 16.4 −6 dBm (±1 dB)

Port 3 TEST IF C 16.2 −6 dBm (±1 dB)

Port 4 TEST IF D 16.1 −6 dBm (±1 dB)

Port 1 REF IF D 16.8 −13 dBm (±1 dB)

Port 1 REF IF R 16.33 −10 dBm (±1 dB)

Port 2 REF IF C 16.4 −13 dBm (±1 dB)

Port 2 REF IF R 16.2 −10 dBm (±1 dB)

Port 3 REF IF A 16.2 −13 dBm (±1 dB)

Port 3 REF IF R 16.56 −10 dBm (±1 dB)

Port 4 REF IF B 16.1 −13 dBm (±1 dB)

Port 4 REF IF R 16.20 −10 dBm (±1 dB)
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System Operation Check

The operator’s check procedure confirms that the system functions normally. There are no 
hard specifications for the system measurement performance, only general guidelines are 
provided for evaluating the operator’s check results.

Technical judgment is required when evaluating the results. The purpose of the operator’s 
check is to detect significant degradations in the system that make the performance 
unacceptable. The calibration kit and test environment can affect the operation check 
results. Refer to “Site Preparation” on page 3-2 and Table 2-5.

When any part of the operator’s check provides unsatisfactory results, troubleshoot the 
system to determine the cause of the problem.

Required Equipment

• A calibration kit compatible with the millimeter wave heads.

• Two waveguide extension sections (provided as accessories for the heads or as part of a 
calibration kit).

Information Required for the Operator’s Check

• From the OML Web site:

❏ Note the specification for Coupler Directivity on the specifications page for the 
particular model head at http://www.omlinc.com/vector/vmodules.htm.

• From the data pages provided by OML for individual heads:

❏ Reference the Dynamic Range and Ref Port/Test Port pages for each OML head for 
use in the operator’s check process defined below.

OML ships three pages of data with each head: Power curve, Dynamic Range, and 
Ref Port/Test Port. If this data is not available, contact OML at 408-779-2698 –  
provide your model and serial numbers and OML will fax the page to you.

• From the calibration kit information:

❏ Note the lower cut-off frequency for the wave guide (“TE 1.0" or “Min”).
❏ Note the length (in mm) of 1/4 wave offset shim.
❏ Note the delay time for a waveguide section (50 mm = 167 picoseconds).

Preparing the PNA-X

1. Connect the PNA-X, the N5261/62A, and the OML banded millimeter-wave heads as 
described in “System Setup with N5242A” on page 3-3.

2. Turn On the N5261/62A and the PNA-X.

3. Configure the PNA-X for operation with the OML heads. Refer to “Controlling the 
N5261/62A with the N5242A” on page 3-10. For further information use the Help menu 
in the PNA-X. Search the Help index for the keyword “N5261/62A” to find the 
appropriate information. The multiplier factors for the OML heads may be read from 
the labels near the connectors on the heads or from the OML Web site at: 
http://www.omlinc.com/vector/vmodules.htm 
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Operator’s Check Procedure

An Agilent or an OML calibration kit may be used with the system. The Agilent calibration 
kit definition is included with the PNA-X firmware. If an OML calibration kit is used with 
the heads, the calibration kit definition must be entered in the PNA-X. To enter it, use the 
PNA-X function “Import Cal Kit” to import the .ckt file from a floppy disk or USB pen 
drive. (Search the Help index for the keywords “modify calibration kit.”) Include the 
calibration kit serial number in the calibration kit definition name/description. 

Initial System Verification

This procedure verifies that the system is connected correctly and the modules, test set 
and PNA-X are operating properly. To verify the measurement accuracy refer to 
“Calibrated Performance Measurements” on page 4-12.

1. Allow the system to warm up for at least 30 minutes.

2. Attach a waveguide extension section to each module’s waveguide flange port. 

3. Verify that the PNA-X is in Millimeter Mode.

4. To verify the port as a receiver, perform the following steps: 

a. Connect a short to module Port 1.

b. Press [Avg] > IF Bandwidth > 1000 > [Enter]. 

c. Display all four receivers on the PNA-X screen using the following menu selections: 
[System] > Service > Utilities > Receiver Display. 

d. Compare the A,1 and R1,1 traces to the traces on the RefPort/TestPort page from 
OML for the head on Port 1. The general level and shape should be similar but not 
necessarily identical.

e. Move the short to module Port 2.

f. Compare the B,2 and R2, 2 traces to the traces on the RefPort/TestPort page from 
OML for the head on Port 2. The general level and shape should be similar, but not 
necessarily identical.

g. Repeat step e and step f for Port 3 and compare trace 3 C,3 and R3, 3. 

h. Repeat step e and step f for Port 4 and compare trace 4 D,4 and R4, 4.

Figure 4-3 Receiver Display
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i. Remove the short from the module. 

j. Connect the waveguide extension flanges of Port 1 module to Port 2, and Port 3 
module to Port 4 (N5262A) to form through connection. Adjust the feet on the 
modules to insure the mating surfaces are properly aligned before connecting the 
waveguide flanges.

k. Delete the trace 1, S11. Press Trace/Chan > Trace > Delete Trace.

l. Press [Preset] > Trace/Chan > Trace > New Trace. Check S12 and S21. (Check S34 
and S43 for a N5262A 4-Port system). The traces should be within 10 dB of zero. See 
Figure 4-4.

Figure 4-4 Initial S12 and S21 Example

5. Check the dynamic range of each head. 

a. Set the PNA-X for 10 Hz IFBW, display S12, S21,S34 and S43 traces. Press [Avg] > 
IF Bandwidth [10] > [Enter].

b. Verify that both modules ports are connected together to form a through connection.

c. Normalize each trace. Select the trace and press [Memory] > Normalize.

d. Press [Scale] > Reference Level > [−80] > [Enter]. (each trace)

e. Disconnect the two module ports.

f. Connect a load to module Port 1.

g. Compare the S12 trace to the dynamic range data for the OML millimeter head. The 
PNA-X trace should be within 5 dB of the dynamic range data. Refer to the OML 
webpage for your module specifications.
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Figure 4-5 Dynamic Range Trace Example

h. Repeat step f and step g for Port 2, 3 and 4.

i. Remove the load.

6. Verify the coupler directivity of each head. 

a. Set the PNA-X for 10 Hz IFBW. Press [Avg] > IF Bandwidth [10] > [Enter]. 

b. Display receiver A trace. Select [System] > Service > Utilities > Receiver Display. 
Refer to Figure 4-3 on page 4-9.

c.  Double click on the A1 window for a full display. 

d. Connect a short to module Port 1.

e. Normalize the trace. Press [Memory] > Normalize. 

f. Remove the short and connect a load to module Port 1.

g. Observe the response. This is the “rough” coupler directivity. The trace should be no 
greater than 10 dB above the directivity specification for the module. Refer to the 
OML webpage for your module.

h. Repeat step 6 for Ports 2 (B,2), 3 (C,3) and 4 (D,4). 
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Figure 4-6 Directivity Trace Example

Calibrated Performance Measurements

This procedure verifies that the performance accuracy of the system.

1. Attach a waveguide extension section to each module’s port. 

2. Allow the system to warm up for at least 30 minutes.

3. Perform a calibration, using the waveguide Cal kit for your module(s). 

a. Press [Preset].

b. Press [Avg] > IF Bandwidth [1000] > [Enter].

c. Set the media to “Waveguide”. Press [Scale] > More > Media coax/WAVGD. 
(Waveguide will be upper case, coax will be lower case). 

d. Select [Cal] > Start Cal > Cal Wizard. Check “SmartCal (GUIDED Calibration) > 
Next. feature to perform the TRL calibration. Select the number of ports to be 
calibrated and the calibration kit you are using. Save the Cal for future use, if 
desired. The calibration software will guide you through the TRL calibration 
procedure.
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4. Verifying the calibrated system performance.

a. Verify waveguide minimum cut-off frequency of your Cal kit. Select Response > Cal 
> More > Cal Kit.

b. Select your Cal kit > Edit Kit. 

c. Select the short or another standard from the list > Edit.

Figure 4-7 Select Cal Kit

d. Write down the “Min frequency” for use in step e, press OK. 

Figure 4-8 Select Standard
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e. Select Response > Scale > Electrical Delay and enter the “Min frequency” for the 
Cutoff freq. Check Waveguide > OK.

Figure 4-9 Electrical Delay

f. Disconnect the modules and install the load from the Cal Kit onto module Port 1.

g. Display the Smith Chart for S11. Press [Format] > Smith. Verify that the response is 
in the middle of the smith chart.

Figure 4-10 Calibrated Load
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h. Connect a short to module Port 1 and verify that the point has moved to the left side 
of the smith chart.

Figure 4-11 Calibrated Short

i. Connect the 1/4 wave and a short to module Port 1. Verify the response (arc) on the 
right side.

Figure 4-12 1/4 Wave with Short Response

j. Remove the 1/4 wave & short and connect the airline (or standard section) to Port 1.

k. Connect the airline (or standard section) to Port 1.

l. Connect a short to the open end of the airline.
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m. Press [Marker] > Marker1. The frequency of the marker should be approximately in 
the middle of the displayed frequency range.

n. Adjust electrical delay using the following menu selections: 

• Select Response > Scale > Electrical Delay and increase the electrical delay until 
the trace is a small cluster on the left side of the Smith Chart’s X-axis. 

• Read the electrical and physical delay values. The physical delay should be 
approximately twice the length of the airline waveguide section in millimeters. 

Figure 4-13 Waveguide Cutoff Frequency

Figure 4-14 Small Cluster
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o. Add a 1/4 offset shim (with the short) to the airline. The Smith Chart trace should be 
an arc on the right side.

p. Increase the electrical delay to minimize the length of the ark on the left side of the 
Smith Chart. Read the electrical and physical delay values. The physical delay 
should be approximately twice the length of the airline waveguide section + the 
1/4 offset shim in millimeters.

q. Remove the airline and install the short on module Port 1.

r. Verify the trace is approximately 0 dB. Press [Meas] > S11 > [Format] > Log Mag.

s. Remove the short and connect the load.

t. Compare the trace to the return loss specification of the load (> −10 dB). Refer to the 
information in your Cal Kit. 

u. Repeat step f through step t for Ports 2, 3 and 4.

v. Connect Port 1 module to Port 2, and Press [Meas] > S11 and S22. The test set solid 
state switch loads will have a return loss of < −10 dB. 

w. Connect Port 3 module to Port 4. Press [Meas] > S33 and S44. The test set solid state 
switch loads will have a return loss of > −10 dB.
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Theory of Operation Functional Block and Assembly Information
Functional Block and Assembly Information
The N5261A/62A routes PNA-X LO and RF signals to a millimeter head module. This 
allows the PNA-X to up-convert for a millimeter-wave source and down-convert a received 
millimeter-wave frequency to an IF frequency < 20 MHz. It also provides the DC power for 
the millimeter heads. The following components are used in the N5261/62A. Refer to the 
block diagrams, Figure 5-1 through Figure 5-4 beginning on Page 5-5.

Test Set Controller Board (N5261-60006)

The Test Set Control Board (N5261-60006) is a surface mount, printed circuit assembly 
(PCA) that provides a connection to the power supply, and the PNA-X Test Set I/O. The 
PNA-X sends address and data commands which are read by the Test Set Controller for 
selecting the switch paths of the SRC1 and SRC2 RF and IF switch paths. The Test Set 
Controller board has a programmed FPGA and memory (NovRam) with model number and 
gain correction values for the Amplifiers and ALC circuits. Switch S1 is set to lock the 
memory after calibration is been loaded.The front panel “Active” and port LEDs are only 
on when the PNA-X has addressed the N5261/62A Millimeter Head Controller. The rear 
panel fan is on when the controller board supplies are operational.

Interface Board (N5261-60001)

The Interface board is installed on top of the Test Set Controller Board. It provides switch 
drive signals and voltage for the solid-state switches that select RF Inputs (SRC1 or SRC2) 
to one of the front panel RF Outputs ports. It provides switching from the front panel 
TEST IF and REF IF Inputs to the rear panel IF Outputs D/R2 C/R1, R, A, B. The 
Interface board also provides DC voltage and ALC control of the Amplifiers. The Interface 
board has a FPGA programmed device that enables N5261/62A Millimeter Head 
Controller operation.

LED Board (N5261-60005)

Two LED board assemblies are mounted to the front panel. The top LED board indicates 
the Source Path (amber/yellow color), or Receiver Path (green colored) shown as “S” and 
“R” for each Port. The bottom LED Board indicates when the Millimeter Heads (green) DC 
Power is on, or if a over-current condition occurs (amber/yellow), which could be a result of 
a shorted interface cable or damaged Millimeter Head module. The LED board assemblies 
are connected to the Test Set Controller board by ribbon cables. 

DC Power Board (N5261-63002)

The DC Power board provides connection to the power supply and self recovering fuses for 
each Millimeter Head supply (+12 volt) on the front panel. The fuses are reset when the 
N5261/62A is turned off. 
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Power Supply (0950-4729)

The power supply (0950-4729) coverts the AC line voltages to DC. This is an automatic line 
voltage selecting power supply. The DC supplies are connected to the test set control board 
through five wire harnesses to connectors J10, J11, J12, J13 and J14. The DC Power board 
is connected to connectors J5 and J8. The AC line voltage (100 to 240 V @ 50/60 Hz) is 
provided from the line module located on the rear panel. 

Isolators (0955-1595)

Isolators are installed in the LO Output RF path for each port. These 10 watt isolators 
maximizes the LO power input to the Millimeter heads over a frequency range of 8 to 
19 GHz.

AMP, LO Power (5087-7290)

An amplifier installed in the LO Input path provides RF power required for the LO Out to 
the Millimeter Head Modules. This amplifier has an attenuator on its input to provide a 
good match and ensure the amplifiers output does not exceed +15 dBm. 

MOD AMP, RF and LO (5086-7523)

The Mod/Amp has adjustable gain that provides ALC leveling for the front panel RF and 
LO Outputs. Adjustments are made on each Mod/Amp to set the maximum output power 
to +12.5 dBm (R3). The output of each amplifier is connected to a coupler, and with a 
detector for ALC, the mod/amps provide RF and LO leveling. Gain values stored on the 
Test Set Controller board are used to provide a set RF and LO level when the ALC is 
turned off in the PNA-X Millimeter mode. Each Mod Amp has a Bias board (N5261-63003) 
installed on top that provides the power supply connection and circuitry for setting the 
gain of the amplifier (R3) and an SMB Input to the modulator.

Attenuator, 6 dB (0955-0243)

The 6 dB attenuators are used to attenuate the RF and LO power to the ALC detector to 
set the RF level for linear operation. 

Attenuator, 3 dB (0955-0246)

The 3 dB attenuators are used in the SRC1 or SRC2 Mod/Amp Inputs to provide a good 
match and ensure it does not exceed +15 dBm. 

Coupler (0955-0148)

Directional couplers with 10 dB coupling factor are used for ALC feedback for RF and LO 
Output leveling.
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Power Divider (N5262-80003)

A four-way power divider provides each Port LO Output from the LO amplifier with 
approximately 7.2 dB attenuation for each LO Out. Two 50 ohm terminators are installed 
on the unused N5261A divider paths. If a system is configured with a unused port (a 1 port 
reflection system for example) the front panel LO Output ports are to be terminated with a 
50 ohm load (1810-0118). This keeps the power divider balanced and prevents an “open” 
reflective signal from entering the power divider and mixing with the RF signal.

Solid State Switch (5087-7223)

A solid-state switch with internal 50 ohm termination is used for switching the RF Output 
path for Ports 1 and 2, or Ports 3 and 4. These switches are controlled by the Test Set 
Controller and Interface Boards.
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Figure 5-1 N5261A Block Diagram

N5261A RF Block Diagram
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Figure 5-2 N5262A Block Diagram

N5262A RF Block Diagram
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Figure 5-3 IF Routing 2-Port

Figure 5-4 IF Routing 4-Port
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